← All Advisories

Apache Log4j RFC 5424 Layout Vulnerable to Log Injection in Versions 2.21 through 2.25

Last refreshed2026-09-26

Status: UPDATED  |  Advisory ID: CVE-2026-34478

Key Details

CVECVE-2026-34478
CVSS Score / Version7.5 (High) / CVSS v3.1
Updated2026-09-24
CVSS VectorCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
CVSS Proseattack vector is network; attack complexity is low; privileges required is none; user interaction is none; scope is unchanged; confidentiality impact is none; integrity impact is high; availability impact is none.
Affected productsApache Log4j
Classified asCWE-117 (Improper Output Neutralization for Logs)
Exploitation prediction (EPSS)1.19% probability of exploitation in the next 30 days (67% percentile) -- FIRST.org's EPSS model.

Affected Products, Subsystems & Sectors

VendorProductAffected VersionsPatch Status
ApacheLog4j
SubsystemsGeneral OT
SectorsMultiple

What to Know

Apache Log4j Core's Rfc5424Layout https://logging.apache.org/log4j/2.x/manual/layouts.html#RFC5424Layout , in versions 2.21.0 through 2.25.3, is vulnerable to log injection via CRLF sequences due to undocumented renames of security-relevant configuration attributes.

Two distinct issues affect users of stream-based syslog services who configure Rfc5424Layout directly:

* The newLineEscape attribute was silently renamed, causing newline escaping to stop working for users of TCP framing (RFC 6587), exposing them to CRLF injection in log output.

* The useTlsMessageFormat attribute was silently renamed, causing users of TLS framing (RFC 5425) to be silently downgraded to unframed TCP (RFC 6587), without newline escaping.

Users of the SyslogAppender are not affected, as its configuration attributes were not modified.

Users are advised to upgrade to Apache Log4j Core 2.25.4, which corrects this issue.

What to Do

Monitor Apache's web page for any future patch releases. See vendor advisory link below.

References

SourceReference
NVDhttps://nvd.nist.gov/vuln/detail/CVE-2026-34478
CVEhttps://www.cve.org/CVERecord?id=CVE-2026-34478
Vendor advisoryhttps://lists.apache.org/thread/3k1clr2l6vkdnl4cbhjrnt1nyjvb5gwt